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irst of all we should explain
what skinning is. It has
nothing to do with dubious
drug-taking practices, instead

it refers to a way of customising games by
creating replacement textures for the
player characters, usually in first-person
shoot-’em-ups. Huge online communities
of skinners have formed for the most
popular games, each with a website where
people post their creations, swap tips and
release utilities.

We’re going to show you how to create a
skin for Quake 3’s Major character model.
Our character will be a female cyborg called
Cyba, but the basic principles can be
applied to any character.

Under the skin
In order to make your own Quake 3 skins
you will need a copy of Quake 3 (of course)
and a paint package, ideally one that
supports layers, such as Photoshop. A
graphics tablet is also highly recommended
as it will make shading your textures much
easier. Once painted your skin must be
converted into a form that Quake 3 can use.

Quake 3 stores its data in .pk3 files

located in its baseq3 folder. These files are
actually ZIP format archives that can easily
be created and decompressed with the
shareware utility ZipIt. The main player
models and textures, which you will want
to extract for reference, are stored in the
pak0.pk3 file. However, as it weighs in at
over 450MB, it can take an extremely long
time to expand! 

Fortunately Quake 3 enthusiasts Tom
Naughton and Toby Allen have written a
utility called PakRat for browsing the
contents of compressed .pk3 files. You can
even view models complete with their
textures and animations. PakRat can
currently handle Quake 1, 2, 3, Hexen 2 and
Voyager Elite Force data files. Although it’s
in alpha we found it to be very stable.

Quake 3’s data is stored within a
hierarchy of folders which we’ll need to
recreate when producing a skin. The player
models are stored in Models, Players with a
further folder for each character. Player
models are composed of several separate
parts, normally lower and upper body and
head sections. They then have skins which
consist of one or more 24-bit Targa format
textures and, to specify which texture

should be applied to each model part, skin
scripts. These scripts can be written in any
text editor such as SimpleText or BBEdit. By
default most player models have multiple
skins which you select in Quake 3 through
the player models options screen.

Quake 3 has the most advanced 3D
graphics engine of any first-person-shooter.
Part of its power and flexibility comes from
a shader scripting system that enables skin
designers to control how models and their
textures are rendered in the game. You
could, for example, give a character
glowing, pulsing eyes or make parts of
their skin reflective. In our example skin
we’ll demonstrate a simple shader that
gives sections of Cyba’s skin a glossy finish.
A complete manual of shader script
commands can be found online at
www.heppler.com/shader/.

The Cyba skin’s layered Photoshop
documents, flattened Targa textures and
skin and shader scripts are included on the
Cover CD along with the final .pk3 file ready
for use in Quake 3 and copies of ZipIt and
PakRat. For more information about
creating Quake 3 skins or skinning other
games, visit www.skindom.com.

Quake 3 skinning
F

Create a folder on your hard disk called “Cyba” to
keep the skin files in. Run PakRat. Select File >
Open... and load the pak0.pk3 data file from your

copy of Quake 3’s baseq3 folder. In the listing window expand
the models, players and major folders as shown. Tick Options
> Assemble Models, scroll down the listing and double-click
on the lower.md3 file to open the Major model.

1 Tick Options > Texture. You can click and drag on the
model view to rotate it, S-drag to zoom and
[control]-drag to move it. Holding down C and

pointing at a part of the model displays the texture map used
on it. Holding down C-O while pointing displays a flattened
mesh of the area covered by the texture.

2 Display the body’s texture map, click and drag it to
the Cyba folder to make a clipping and rename it
“body texture”. Then view the body’s flattened

mesh, drag it to the Cyba folder and call it “body mesh”.
Repeat the process for the head, calling the files “head
texture” and “head mesh” respectively. Quit PakRat.

3

Tutorial 1: Extracting templates with PakRat
The PakRat utility will enable you to browse the contents of compressed .pk3 files from all versions of Quake, plus

Hexen 2 and Voyager Elite Force.

words Brian Smith
Follow our beginners’ guide to Quake 3 skinning and plunge your own
customised warrior into the arena eternal.

The files you’ll need for
this tutorial are on the

Cover CD
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With the design planned out you can hide the mesh
layer and add shading using the airbrush and soft-
edged brushes. You should shade the texture so it

looks like the player model is lit from above. When you are
happy with the shading you can add some colour.

7 Select Layer > New > Layer... to create a new layer.
Rename it “Colour” and drag it in the Layer palette
so it is directly above the shading layer. Fill the

colour layer with white and then use the pop-up menu at the
top of the Layers palette to change its blending mode to
Colour. Colour the texture with the airbrush.

8 Select File > Save... and back up the image as a
Photoshop document called “cyba.psd” (when you
paint the head texture it should be saved as

“cyba_h.psd”). At this stage the textures could be flattened
and saved as Targa files for use in Quake 3 but instead we’re
going to add a shader to the skin to make Cyba’s body shiny.

9

Double-click the hand tool button in the tool palette
to zoom the image so it fills the available screen
space. We’ll hide the guide texture by clicking on the

eye icon next to its name in the Layers palette. Now change
the background layer’s name to “Shading”.

4 Click on the background colour swatch in the tool
palette and pick a grey with hue 0º, saturation 0%
and brightness 50%. With the shading layer selected

in the Layers palette press C-[delete] to fill it with grey. This
gives us a nice mid-tone to base our shading on later.

5 Now we can start drawing the skin. Using the
airbrush tool with a small diameter brush, sketch in
the basic design. Remember that you can refer to the

guide texture by clicking on the eye icon next to it in the
Layers palette. It may also help you to run PakRat and view
the guide texture actually applied to the Major model.

6

Launch Photoshop. Select File > New... to create a
blank document. Call it “Cyba” and give it a
resolution of 256 x 256 pixels, 72dpi and the RGB

colour mode.

1 Drag the body texture clipping from your hard disk
onto the Photoshop document window. It will
appear on a new layer above the background in the

Layers palette. Double-click on the new layer’s name and
change it to “guide texture”. Now drag the body mesh
clipping onto the image and rename its layer mesh.

2 To make the mesh easier to refer to we’ll make it
black on white, by selecting Image > Adjust > Invert,
and transparent by reducing the mesh layer’s

opacity in the Layers palette to 15%. We can now refer to the
mesh and guide texture layers as we work to see how the
texture maps to the Major model’s polygons.

3

Tutorial 2: Painting textures in Photoshop
Here we are going to explain how the body texture was painted – the same technique was used to create the head

texture.

MF105.skinning  25/5/01  1:52 pm  Page 63



064 | MacFormat | #105 July 2001

Next we’ll paint an environment map to be reflected
in the bodywork. Make a new document called
“envmap” with a resolution of 64 x 64 pixels and

RGB colour mode. Fill it with black and paint in random brown
and orange squiggles as shown. Save the resulting image as a
24-bit Targa called “envmap.tga”. Quit Photoshop.

4 Now we can write the shader script. Launch BBEdit
and, if it doesn’t open a blank document, select File
> New > Text Document. Each shader starts with the

file path of the texture it replaces, in this case it will be
“models/players/major/cyba” (don’t include the file
extension). Braces delineate each stage of the script.

5 The “map” command specifies an image and
“rgbGen lightingdifuse” assigns standard lighting.
“tcGen environment” makes “envmap.tga” act as an

environment map and “blendFunc blend” combines the two
textures using the cyba.tga file’s alpha channel. We have to
repeat the shader instructions for the cyba_h.tga texture. File
> Save the finished script as “cyba.shader” and quit BBEdit.

6

First we need to add an alpha channel to the texture
to show in which areas the effect should be applied.
Click on the Channels tab in the Layers palette. Then

click on the document icon at the bottom of the palette to
add a new channel and rename it “Shader”.

1 Pick a grey foreground colour with hue 0º, saturation
0% and brightness 60%. Un-hide the RGB channel.
Then, with the shader channel selected, use a soft-

edged brush to shade over the orange body panels as shown.
Invert the shading so the alpha is darkest over the highlights
and lightest over the shadows.

2 Back up the change you have made to the texture by
selecting File > Save. Make sure the mesh and guide
texture layers are hidden, pick Layer > Flatten Image

and OK the dialogue box that appears. Then File > Save As...
and save the image as a 32-bit Targa file called “cyba.tga”
(when you complete the head texture save it as “cyba_h.tga”).

3

Tutorial 3: Adding a shader
Here’s how to make a shader to add shine to your skin’s body panels, and to write the script for it, so you can select it

in Quake 3’s player model options screen.
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The icon needs an alpha channel. With the Magic
Wand select the image’s background (hold down S

to make non-contiguous selections). Choose Select >
Inverse. Click on the Channels tab in the Layers palette and
then click on the Save Selection as Channel button at the
bottom of the palette. Drop the selection by pressing C-D.

7 Select File > Save As... and save the image inside the
Major folder as a 32-bit Targa file called
“icon_cyba.tga”. Quit Photoshop. In the Finder open

the Major folder on your hard disk and trash the head.md3,
upper.md3, lower.md3 and animation.cfg files.

8 Launch ZipIt. If it doesn’t create a blank archive use
File > New. Select Zip > Add... and add the Models
and Scripts folders on your hard disk to the archive.

Click Done. Pick File > Save and save the archive as “cyba.pk3”.
To use the skin place the cyba.pk3 file in Quake 3’s baseq3
folder and select Cyba in Quake’s player model options screen.

9

Our skin needs a portrait icon. We could paint it but
it’s quicker to grab one in PakRat. To do this we will
have to add some files temporarily to our folders. Go

back to PakRat and drag the head.md3, upper.md3, lower.md3
and animation.cfg files into the Major folder on your hard
disk. In PakRat select File > Close.

4 File > Open... and load the lower.md3 file from your
hard disk. Expand the folders in the listing window
and double-click on lower.md3 to view the Cyba skin

applied to the Major model. Press C-S-3 to grab a screen
shot. It will be saved to the root of your hard disk as a Pict file
called Picture 1. Quit PakRat.

5 Launch Photoshop and select File > Open... to load
the Picture 1 grab. Use the Crop tool to pick a nice
section, holding down S while making the selection

to ensure it is square. Choose Image > Image Size... and
reduce the image to 64 x 64 pixels. This will smooth out the
jagged pixels at the edges of the model.

6

First we need the correct folder structure. Inside the
Cyba folder create a folder called “Scripts” (only
needed because we are adding a shader script to the

skin) and a set of nested folders called “Models”,“Players” and
“Major” as shown. Drag the cyba.tga, cyba_h.tga and
envmap.tga files into the Major folder and the cyba.shader
file into the Scripts folder.

1 Next we need to add some skin files which define
how the textures are applied to the model. Launch
PakRat and open Quake 3’s pak0.pk3 data file.

Navigate to the Major player model folder in the listing
window and drag the head_default.skin, lower_default.skin
and upper_default.skin files to the Major folder.

2 In the Finder change the “default” portion of the
skin filenames to “cyba”. Then with BBEdit open each
skin file in turn and edit the texture file paths so

they point to your new textures, ie. change the references to
“major.tga” to “cyba.tga” and “major_h.tga” to “cyba_h.tga”.

3

Tutorial 4: Making a .pk3 file
Now the creative work’s done, and we’re on the final steps. Put all those files in the correct places with appropriate file

names, make an icon of your character, and create an archive that Quake can read.
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